Abschaltung von PHP 5.4 zum 8. Januar 2020

Da uns Sicherheitsthemen wichtig sind, haben wir im Laufe der Zeit eine neue technische Struktur eingeführt, die viele Nutzer mit noch mehr Domains bereits nutzen und damit z.B. auch kostenlose Zertifikate mit Let’s Encrypt ermöglicht.

Um diesen Prozess abzuschließen, erfolgt nun die vollständige Umstellung unserer Infrastruktur.
Wer von dieser Umstellung betroffen ist, hat von uns eine Information per E-Mail erhalten mit den betroffenen Domains. Diese werden zum 8.1.2020 umgestellt.
Wir gehen nicht davon aus, dass Einschränkungen in der Domainnutzung auf Dich zukommen.

Natürlich ergeben sich zur Umstellung auch ein paar Fragen, die wir hier versuchen, zu erläutern:

Bin ich von der Umstellung betroffen?

In der Regel sind alle Domains und deren Subdomains betroffen, die vor 2015 registriert wurden und die bis heute nie durch unseren Support angehoben wurden.
Alle betroffenen Kunden wurden von uns per E-Mail angeschrieben. Zudem kannst Du in der Regel im Einstellungsbereich Deiner Domain sehen, ob diese (noch) auf PHP 5.4 betrieben wird.

Wann findet die Umschaltung statt?

Über den Zeitpunkt der Umschaltung informieren wir per E-Mail. Die Umschaltungen sind ab dem 8. Januar 2020 geplant und können einige Tage in Anspruch nehmen.

Welche PHP-Version wird nach der Umstellung genutzt und ist die Version aktuell?

Um die Auswirkungen zunächst möglichst gering zu halten, schalten wir ab 8. Januar 2020 alle Domains mit PHP 5.4 zwangsweise auf PHP 5.5 um – ein sehr kleiner Versionssprung. Unter der Adresse https://www.php.net/migration55 findest Du und Deine Programmierer Hinweise zu notwendigen Anpassungen.

Wie lange wird die dann genutzte PHP-Version 5.5 unterstützt?

Auch die dann von uns eingesetzte PHP-Version 5.5 ist bereits veraltet und wird bei uns in Kürze durch PHP 7.3 ersetzt werden. Nach der Umschaltung hast Du jedoch in unserem Verwaltungs-Interface die Möglichkeit, Deine Webseite in aller Ruhe und Schritt-für-Schritt auf das derzeit aktuelle PHP 7.3 zu aktualisieren, die wir dann langfristig unterstützen. Gehe die Upgrades auf die aktuellsten Versionen in Ruhe in den nächsten Wochen und erst nach der Umstellung an. Eine ausführliche Anleitung zu den weiteren Updates auf PHP 7.3 findest Du auf https://www.jpberlin.de/hilfe/webspace-webseiten/php-update/.

Kann ich meine Domain ohne Änderung nach dem 8.1.2020 weiter mit dem jetzigen PHP 5.4 betreiben lassen?

Leider nein. PHP 5.x ist bereits seit etlichen Jahren veraltet und erhält keine Security-Updates mehr. Wir haben lange versucht, unseren Kunden den bequemen Weiterbetrieb zu ermöglichen. Doch nun sind wir an dem Punkt angekommen, wo eine weitere Unterstützung von PHP 5.4 unverantwortlich wäre und auch die Sicherheit der Daten unserer Kunden gefährden würde.

Welche Änderungen ergeben sich?

Neben den Änderungen bei PHP (siehe weiter oben) ändert sich bei dieser Gelegenheit auch die Dateistruktur auf unserem Server. In sehr seltenen Fällen haben Programmierer feste Dateipfade in Ihren Anwendungen verwendet (z.B /srv/www/htdocs/www.example.com), die angepasst werden müssen. Bitte verwende stets relative Pfade.

Die neuen Server werden zudem nicht mehr mit Apache 2.2, sondern Apache 2.4 betrieben. Webmaster finden auf http://httpd.apache.org/docs/2.4/upgrading.html eine Übersicht über alle notwendigen Anpassungen.

Beachte dabei, dass sich auch der Syntax der beliebten .htaccess-Dateien geändert hat.
Statt wie bisher

Order Deny,Allow
Deny from All

sollten Sie neuerdings

<Files „*“>
<IfModule mod_version.c>
<IfVersion < 2.4>
Order Deny,Allow
Deny from All
</IfVersion>
<IfVersion >= 2.4>
Require all denied
</IfVersion>
</IfModule>
<IfModule !mod_version.c>
<IfModule !mod_authz_core.c>
Order Deny,Allow
Deny from All
</IfModule>
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
</IfModule>
</Files>

verwenden, statt

Order Allow,Deny
Allow from All

nun

<Files „*“>
<IfModule mod_version.c>
<IfVersion < 2.4>
Order Allow,Deny
Allow from All
</IfVersion>
<IfVersion >= 2.4>
Require all granted
</IfVersion>
</IfModule>
<IfModule !mod_version.c>
<IfModule !mod_authz_core.c>
Order Allow,Deny
Allow from All
</IfModule>
<IfModule mod_authz_core.c>
Require all granted
</IfModule>
</IfModule>
</Files>

Die derart präparierten .htaccess-Dateien sind dann unter Apache 2.2 und 2.4 gleichzeitig lauffähig und die Änderungen sollten damit schon vorab vorgenommen werden.

Ich benutze ein CMS wie WordPress oder Joomla. Was muss ich berücksichtigen?

Bitte führe schon vor unserem PHP-Upgrade ein Update auf die neueste verfügbare WordPress- oder Joomla-Version für die jeweilige PHP-Version durch, um sicherzustellen, dass diese auch mit neueren PHP-Versionen lauffähig ist. Diese Versionen berücksichtigen dann auch die oben genannten ggf. notwendigen Anpassungen zum Betrieb mit Apache 2.4.

Was mache ich, wenn meine Domain nach der Umstellung nicht geht?

Kontaktiere bitte Deinen Webmaster oder Programmierer – idealerweise schon im Vorfeld der Umstellung. Eventuell ist es hilfreich, schon im Vorfeld eine Bereitschaft des Webmasters/Programmierers für den Zeitraum der Umstellung abzusprechen.

Kann auch der JPBerlin-Support bei Problemen meine Webseite reparieren?

Leider nein. Sollten Probleme auftreten, erfordert dies Zugriff und Änderungen in Deinen PHP-Code und/oder Deiner .htaccess-Datei.

  • 8. November 2019

  • o.graeber

  • Keinen Kommentar


Kommentar abgeben

Sie müssen eingeloggt sein um zu kommentieren.